Last Updated:
Friday, 27 February 2009 By: Steve Warner

Home | About Us | Standards | Cisco IOS© | Cisco CCNA© | Cisco CCNP© | Cisco CCIE© | Security | VoIP | Configs | Links

Search

CCNP™

BGP4 Peering Setup

 


  Peering Interface
interface FastEthernet0/1/0
 description LINX 100Mbit Fast Ethernet
 ip address 192.128.0.1 255.255.254.0
 ip access-group 101 in
 no ip redirects
 no ip directed-broadcast
 no ip proxy-arp
 ip route-cache flow
 ip route-cache distributed
 full-duplex
 no cdp enable
router bgp 1234
 no synchronization
 bgp log-neighbor-changes
 bgp dampening route-map graded-flap-damp
 bgp deterministic-med
 network 194.38.218.0 route-map announce

 neighbor internal peer-group
 neighbor internal remote-as 1234
 neighbor internal update-source Loopback0
 neighbor internal send-community

 neighbor linx peer-group
 neighbor linx soft-reconfiguration inbound
 neighbor linx route-map linx-in in
 neighbor linx route-map linx-out out
 neighbor linx filter-list 2 out

 neighbor 195.66.224.10 remote-as 2856
 neighbor 195.66.224.10 peer-group linx
 neighbor 195.66.224.10 maximum-prefix 500 95
 neighbor 195.66.224.10 filter-list 101 in
 neighbor 195.66.224.12 remote-as 2529
 neighbor 195.66.224.12 peer-group linx
 neighbor 195.66.224.12 filter-list 102 in

 no auto-summary
!
ip bgp-community new-format
!
ip as-path access-list 2 permit ^$
ip as-path access-list 101 permit ^2856(_(1752|1830|2856|4513|4983|6553|6656|6871|6949|8068|8072|8435|8613|8635|8689|8698|8718|8743|9090|9195|9498|10348|12801|12937|13037|13108|13114|13196|15727))*$
ip as-path access-list 102 permit ^2529(_(2529|54(17|28|59)|55(00|64)|6749|8539|8796))*$

ip prefix-list rootns description Root-nameserver networks
ip prefix-list rootns seq 5 permit 198.41.0.0/24
ip prefix-list rootns seq 10 permit 192.112.36.0/24
ip prefix-list rootns seq 15 permit 198.17.208.0/24
ip prefix-list rootns seq 20 permit 192.5.4.0/23
ip prefix-list rootns seq 25 permit 192.36.148.0/24
ip prefix-list rootns seq 30 permit 192.203.230.0/24
ip prefix-list rootns seq 35 permit 195.8.96.0/19
ip prefix-list rootns seq 40 permit 198.41.3.0/24
ip prefix-list rootns seq 45 permit 210.176.0.0/16
ip prefix-list rootns seq 50 permit 216.33.64.0/19
ip prefix-list rootns seq 55 permit 205.188.128.0/17

access-list 100 permit ip 192.41.177.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip 198.32.130.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip any 255.255.255.128 0.0.0.127
access-list 100 permit ip host 0.0.0.0 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 255.0.0.0 0.255.255.255
access-list 100 permit ip 10.0.0.0 0.255.255.255 255.0.0.0 0.255.255.255
access-list 100 permit ip 172.16.0.0 0.15.255.255 255.240.0.0 0.15.255.255
access-list 100 permit ip 192.168.0.0 0.0.255.255 255.255.0.0 0.0.255.255
access-list 100 permit ip 192.0.2.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip 128.0.0.0 0.0.255.255 255.255.0.0 0.0.255.255
access-list 100 permit ip 191.255.0.0 0.0.255.255 255.255.0.0 0.0.255.255
access-list 100 permit ip 192.0.0.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip 223.255.255.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip 198.32.136.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip 149.20.0.0 0.0.255.255 255.255.0.0 0.0.255.255
access-list 100 permit ip 198.32.128.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip 192.157.69.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 permit ip 224.0.0.0 31.255.255.255 224.0.0.0 31.255.255.255
access-list 100 permit ip 195.66.224.0 0.0.1.255 255.255.254.0 0.0.1.255
access-list 100 deny   ip any any

access-list 181 permit ip any 255.255.255.0 0.0.0.255
access-list 181 deny   ip any any
access-list 182 permit ip any 255.255.252.0 0.0.3.255
access-list 182 deny   ip any any
access-list 189 deny   ip any any

route-map linx-in deny 10
 match ip address 100
!
route-map linx-in permit 20
 set local-preference 100
 set community 1234:80 1234:3000
!
route-map announce permit 10
 set community 1234:4000
!
route-map linx-out deny 10
 match community 1
!
route-map linx-out permit 20
 set metric 45

route-map graded-flap-damping deny 5
 match ip address 189
!
route-map graded-flap-damping deny 7
 match ip address prefix-list rootns
!
route-map graded-flap-damping permit 10
 match ip address 181
 set dampening 30 750 3000 60
!
route-map graded-flap-damping permit 20
 match ip address 182
 set dampening 15 750 3000 45
!
route-map graded-flap-damping permit 40
 set dampening 10 1500 3000 30


 

 

Valid HTML 4.01!

ExamPointers.com Top

Copyright 2001 - 2017. All trademarks acknowledged.
Hosted by NETconf Limited